Wirexapp application performance degradation
Incident Report for Wirex
Resolved
We confirm that the aforementioned issues have been resolved. The application is fully available. Thanks for the patience shown
Posted Nov 14, 2023 - 18:28 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 14, 2023 - 16:25 UTC
Identified
Affected service: Application

Affected region: All

Description: Considering the ongoing incident on 3rd party side, we may observe performance degradation which may affect application responsiveness. Our technicians are currently investigating the issue and will update you as soon as we know more.
Posted Nov 14, 2023 - 16:23 UTC
This incident affected: Wirex Applications (Web Application, Android Application, iOS Application).