3DS Biometric confirmation degraded performance

Incident Report for Wirex

Resolved

This incident has been resolved.
Posted Feb 14, 2026 - 20:27 UTC

Identified

Description:
We have identified the unstable behaiour in 3DS Biometric confirmation request processing. Our technicians are looking into the problem. As the main workaround we advise using SMS confirmation.
Posted Feb 13, 2026 - 10:15 UTC