Card operations(card details/block/reissue/order) + 3DSecure service unavailable

Incident Report for Wirex

Resolved

All functionalities have been restored. Thanks for the patience shown
Posted Mar 17, 2025 - 21:41 UTC

Update

3DSecure payment confirmation is available
Posted Mar 17, 2025 - 21:12 UTC

Update

Card operations have been temporary disabled.
Posted Mar 17, 2025 - 20:31 UTC

Identified

Region: EEA+UK
Description:
According to the critical incident on 3rd party provider, card operations (reissue/order/block/freeze/card details view) and 3DSecure payment confirmation (Biometric and SMS affected) are unavailable. No impact on payment processing.
Posted Mar 17, 2025 - 20:06 UTC
This incident affected: Wirex Card.