FIAT and Crypto transfers processing delay

Incident Report for Wirex

Resolved

This incident has been resolved.
Posted May 26, 2025 - 00:38 UTC

Update

3rd party sideis aware of the issue and working on fixing it at the moment. We apologize for any inconvenience and will provide you with an update at the soonest possibility.
Posted May 25, 2025 - 11:49 UTC

Identified

Region: EEA, UK, RoW
Description: We have identified the processing delay for FIAT and Crypto transfers due to ongoing incident on 3rd party side. Once the issue is resolved, all affected transactions will be finalized.
Posted May 25, 2025 - 11:43 UTC
This incident affected: Crypto transfers and Fiat transfers.