Exchange operations disabled

Incident Report for Wirex

Resolved

This incident has been resolved.
Posted Mar 14, 2026 - 09:40 UTC

Monitoring

Coin: All
Region: All
Description: Our 3rd party provider started technical maintenance which may cause the unexpected behaviour for specific functionalities. To avoid bad user experience we have disabled exchange operations.
Posted Mar 13, 2026 - 21:27 UTC
This incident affected: Exchange.