Issue with card operations
Incident Report for Wirex
Resolved
This incident has been resolved.
Posted Aug 17, 2023 - 07:46 UTC
Investigating
Affected service: Card operations

Affected region: EEA

Description: We're currently experiencing degraded performance with card processing in the European Economic Area (EEA). Card processing in the UK, APAC, and USA are unaffected and operating normally. Our team is actively working to resolve this issue. Updates to follow. Thank you for your patience.
Posted Jun 23, 2023 - 08:54 UTC
This incident affected: Wirex Card.