Card payouts disabled

Incident Report for Wirex

Resolved

This incident has been resolved.
Posted May 12, 2026 - 08:19 UTC

Identified

Region: EEA + RoW
Description: To avoid bad user experience, we have disabled card payouts until all technical barriers are resolved. Currently, we are waiting for updates from 3rd party provider.
Posted May 06, 2026 - 10:05 UTC