Crypto/FIAT transfers processing delay

Incident Report for Wirex

Resolved

Currently the system is processing all transfers without any barriers. All previously affected will be automatically reprocessed as soon as possible.
Posted Nov 19, 2025 - 18:25 UTC

Monitoring

From 13:30 (UTC), the new transactions are expected to go through without any delays. We are working on fixing all previsouly affected transfers.
Posted Nov 19, 2025 - 13:34 UTC

Identified

Region: All
Description:
We have identified internal technical barriers which may cause processing delay for crypto and FIAT transfers. Our technicians are looking into it. The root cause is known and the hottix is getting being prepared.
Posted Nov 19, 2025 - 13:17 UTC
This incident affected: Crypto transfers and Fiat transfers.