Exchanges disabled due to technical barriers

Incident Report for Wirex

Resolved

This incident has been resolved.
Posted Apr 03, 2026 - 09:38 UTC

Identified

Region: All
Coin: All
Description: In order to avoid bad user experience the decision was taken to disable exchange operations until all technical barriers are resolved. Thanks for the patience shown
Posted Apr 02, 2026 - 11:01 UTC
This incident affected: Exchange.