Verification issue: Survey completion or document submit delays
Incident Report for Wirex
Resolved
This incident has been resolved.
Posted May 25, 2022 - 08:42 UTC
Update
We are continuing to investigate this issue.
Posted May 25, 2022 - 08:42 UTC
Investigating
WINC-2219

Affected service: Verification

Affected region: All

Description: Some users may be asked to repeatedly complete the survey even after the successful first try. Also, please be aware of the possible delay after documents submit.
Our relevant teams are looking into it.
Posted Apr 21, 2022 - 21:49 UTC
This incident affected: Verification.