Exchange operations issue

Incident Report for Wirex

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 23:05 UTC

Investigating

Affected service: Exchanges

Affected Coin: All

Affected region: All

Description: An infrastructure issue is currently affecting exchange operations. To minimize disruption, we have temporarily disabled these functions. The issue is being investigated and we will update you as soon as we know more.
Posted Dec 05, 2025 - 22:26 UTC
This incident affected: Exchange.