Tron infrastructure maintenance
Scheduled for Sep 8, 08:00 - 12:00 UTC
Update
The maintenance time has been rescheduled to September 08, 2024, around 08:00 AM UTC.
Posted Sep 01, 2024 - 07:37 UTC
Scheduled
Coin: all Tron-supported

Network: Tron

Region: All

Description: We will disable In/Out crypto transfers through Tron network due to technical update on our 3rd party partner side.
Posted Aug 29, 2024 - 12:31 UTC