Crypto transfers processing delays

Incident Report for Wirex

Resolved

This incident has been resolved.
Posted Mar 24, 2026 - 12:15 UTC

Identified

Coin: All
Region: EEA+ Rest of the World
Description: We have identified internal technical barriers that affects crypto transaction status finalization. The root cause is known and our technicians are looking into it.
Posted Mar 24, 2026 - 10:50 UTC
This incident affected: Crypto transfers.