Delayed USDC (Polygon) Deposits

Incident Report for Wirex

Resolved

This incident has been resolved.
Posted Jul 08, 2026 - 07:48 UTC

Investigating

We are currently investigating an issue affecting USDC deposits on the Polygon network. As a result, some deposits may be delayed before being credited to customer accounts.

Our engineering team has identified the root cause and is actively working on a fix, which is estimated to be deployed on Monday.
Please note that customer funds remain safe. Any affected deposits will be credited automatically once the issue has been resolved. No action is required from customers.

At this time, we expect the issue to be fully resolved by the end of the day on Monday, July 6th. We will continue to provide updates as more information becomes available.

We apologise for the inconvenience and appreciate your patience.
Posted Jul 02, 2026 - 14:45 UTC
This incident affected: Crypto transfers.