BTC transfers delays detected
Incident Report for Wirex
Resolved
This incident has been resolved.
Posted Aug 08, 2023 - 17:36 UTC
Investigating
Affected service: Incoming/Outgoing transfers

Affected Coin: BTC

Affected region: EEA + RoW

Description: Due to a sudden fee spike on BTC blockchain users may experience intermittent issues with outbound transactions. Resolution is expected in following hours.
Posted Aug 08, 2023 - 13:01 UTC
This incident affected: Crypto transfers.