Wirex Multiply unavailable
Incident Report for Wirex
Resolved
This incident has been resolved.
Posted Jul 01, 2023 - 16:16 UTC
Update
We are continuing to investigate this issue.
Posted Jun 30, 2023 - 22:10 UTC
Investigating
We are currently experiencing temporary service restrictions on Wirex Multiply due to an issue with a third-party provider. Our team is actively working to resolve this problem and we appreciate your patience. We will provide updates as more information becomes available.
Thank you for understanding.
Posted Jun 30, 2023 - 22:08 UTC
This incident affected: Wirex Grow (Multiply).