Issue processing BTC outgoing transactions
Incident Report for Wirex
Resolved
This incident has been resolved.
Posted Oct 15, 2023 - 11:57 UTC
Investigating
Affected service: Outgoing transfers

Affected Coin: BTC

Affected region: All

Description: We may observe some unexpected behaviours in BTC outgoing transactions processing. 3rd party service is already acknowledged about the issue.
Posted Oct 15, 2023 - 11:23 UTC
This incident affected: Crypto transfers.