On-chain crypto deposits processing barriers for USA region
Incident Report for Wirex
Resolved
This incident has been resolved.
Posted Sep 05, 2024 - 14:50 UTC
Identified
WINC-4580

Affected service: Crypto deposits(on-chain only)

Affected Coin: All

Affected region: USA

Description: We have identified issues with crypto deposits. Only USA customers are affected. Our 3rd party provider is acknowledged about the incident. To minimize service disruption, we have temporary hidden account details and their creation requests.
Posted Sep 05, 2024 - 13:29 UTC