3DS Biometric confirmation unstable behaviour

Incident Report for Wirex

Resolved

This incident has been resolved.
Posted Feb 05, 2026 - 18:37 UTC

Identified

Region: All
Description:
3DS Biometric confirmation functionality may be unstable because of ongoing incident. Our technicians acknowledged the problem and the root cause is detected. As a workaround we advise using SMS confirmation alternatively.
Posted Feb 05, 2026 - 11:59 UTC