TRX outgoing transfers disabled

Incident Report for Wirex

Resolved

This incident has been resolved.
Posted Nov 25, 2023 - 10:13 UTC

Identified

We've temporary disabled TRX outgoing transfers due to technical barriers. Relevant teams are involved into the investigation.
Posted Nov 25, 2023 - 00:48 UTC