Wirexapp application experiencing periodical issues

Incident Report for Wirex

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 15:25 UTC

Update

We are continuing to monitor for any further issues.
Posted Nov 18, 2025 - 12:40 UTC

Monitoring

Region: All
Description: According to the global incident on Cloudflare side, our application is also affected by periodical connectivity drops. We are closely monitoring for any updates from their side. Official source - https://www.cloudflarestatus.com/incidents/8gmgl950y3h7
Posted Nov 18, 2025 - 12:05 UTC
This incident affected: Wirex Applications (Web Application, Android Application, iOS Application) and Sign up & Log in.