Card operations unexpected declines

Incident Report for Wirex

Resolved

This incident has been resolved.
Posted Jul 13, 2026 - 12:56 UTC

Investigating

Description: We are aware of the ongoing incident which may affect card operations workability. On user's end some transaction attempts may be failed. The incident is being investigated in a highest priority.
Posted Jul 13, 2026 - 10:46 UTC
This incident affected: Wirex Card.