Issue processing outgoing BTC transactions
Incident Report for Wirex
Resolved
This incident has been resolved.
Posted May 08, 2024 - 08:20 UTC
Investigating
Affected service: Transactions

Affected Coin: BTC

Affected region: All

Description: A processing issue on our partner’s side is currently affecting outgoing BTC transactions. Our partner is working to resolve the issue. We will update you as soon as we know more.

Next update: 2h
Posted May 06, 2024 - 15:19 UTC
This incident affected: Crypto transfers.